Skip to main content
← All vulnerabilities
CVE-2006-4112GHSA-9WRQ-XVMP-XJC8

Unspecified vulnerability in the "dependency resolution mechanism" in Ruby on Rails 1.1.0 through 1.1.5 allows remote attackers to execute a

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 1.1.6
None on Exploit-DB, Metasploit or GitHub

Summary

Unspecified vulnerability in the "dependency resolution mechanism" in Ruby on Rails 1.1.0 through 1.1.5 allows remote attackers to execute arbitrary Ruby code via a URL that is not properly handled in the routing code, which leads to a denial of service (application hang) or "data loss," a different vulnerability than CVE-2006-4111.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • n/a n/a

    Version range not reported

  • railsRubyGems

    From 1.1.0 · fixed in 1.1.6

References 11

secunia.com

securityfocus.com

weblog.rubyonrails.org

exchange.xforce.ibmcloud.com

novell.com

gentoo.org

kb.cert.org

securitytracker.com