Skip to main content
← All vulnerabilities
CVE-2006-4111GHSA-RVPQ-5XQX-PFPP

Ruby on Rails before 1.1.5 allows remote attackers to execute Ruby code with "severe" or "serious" impact via a File Upload request with an

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 1.1.6
None on Exploit-DB, Metasploit or GitHub

Summary

Ruby on Rails before 1.1.5 allows remote attackers to execute Ruby code with "severe" or "serious" impact via a File Upload request with an HTTP header that modifies the LOAD_PATH variable, a different vulnerability than CVE-2006-4112.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • n/a n/a

    Version range not reported

  • railsRubyGems

    From 1.1.0 · fixed in 1.1.6

References 9

secunia.com

securityfocus.com

vupen.com

blog.koehntopp.de

novell.com

weblog.rubyonrails.org

gentoo.org

securitytracker.com