Skip to main content
← All vulnerabilities
CVE-2002-0170PYSEC-2026-758GHSA-C3RP-4CJH-CP38

Zope 2.2.0 through 2.5.1 does not properly verify the access for objects with proxy roles, which could allow some users to access documents

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 2.4.4, 2.5.1
None on Exploit-DB, Metasploit or GitHub

Summary

Zope 2.2.0 through 2.5.1 does not properly verify the access for objects with proxy roles, which could allow some users to access documents in violation of the intended configuration.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • n/a n/a

    Version range not reported

  • zopePyPI

    From 2.2.0 · fixed in 2.4.4; From 2.5.0 · fixed in 2.5.1

  • zopePyPI

    From 2.2.0 · fixed in 2.4.4

  • zopePyPI

    From 2.5.0 · fixed in 2.5.1

References 6

marc.info

zope.org

securityfocus.com

redhat.com

iss.net

osvdb.org